Back to overview
Downtime

DNS Outage

Feb 12, 2026 at 7:23pm UTC
Affected services
Web01 Node - Web Hosting
hosting.fumeblast.com
fpanel.fumeblast.com
billing.fumeblast.com
Web02 Node - Web Hosting

Resolved
Feb 12, 2026 at 7:54pm UTC

This has been resolved

Created
Feb 12, 2026 at 7:23pm UTC

Our datacenter is having a major DNS outage on the node we are on. All of our websites and panels are affected.

Your servers are still up and are reachable

We will provide updates as given