Back to overview
Maintenance

NA1 RAM Upgrades

Feb 26, 2026 at 2:00am UTC  –  Feb 26, 2026 at 2:19am UTC
Affected services
NA1 Node - Game Server Hosting

Resolved
Feb 26, 2026 at 2:19am UTC

This has been completed.

Created
Feb 26, 2026 at 2:00am UTC

We will be upgrading our RAM during this time. This will result in more ram, and faster ram.